Welcome, Guest
Username: Password: Remember me

TOPIC: Exporting as .xlsx

Exporting as .xlsx #2268

  • HPadam
  • HPadam's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Hi Guys,
We're running Synergy Classic V399 and have recently started having an interesting problem. Whenever we export a list of accounts from Synergy, the Excel spreadsheet has an .xlsx extension. The problem is that the exported file is actually an .xls file with the wrong extension. You have to manually edit the file name and remove the extra 'x' otherwise the spreadsheet will not open. I can't find any info on Exact's KB.

Has anyone else come across this before?

Thanks!
The administrator has disabled public write access.

Exporting as .xlsx #2269

  • dgillz
  • dgillz's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 395
  • Thank you received: 14
  • Karma: 6
Nothing wrong, this is an Excel 2007 file. .xlsx is the default extension of Excel 2007.
www.gainfocus.biz
Worldwide support for Macola Progression, Macola ES, Synergy, Event Manager and Crystal Reports.
The administrator has disabled public write access.

Exporting as .xlsx #2270

  • HPadam
  • HPadam's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
I know .xlsx is Excel 2007/2010. The format of the exported spreadsheet is .xls with an extension of .xlsx. If I try to open the file in Excel 2010, I get "Excel cannot open the file 'Export.xlsx' because the file format or file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file." Synergy is exporting the contact list as an .xls file but naming it with an .xlsx extension.

The only workaround is to edit the extension in the file name.
The administrator has disabled public write access.

Exporting as .xlsx #2540

  • be05x5
  • be05x5's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 123
  • Thank you received: 2
  • Karma: 0
Interesting. I am having the same thing except the other way around. The file has a .xls extension. Prior to reading this post I would open the excel and it just had random characters in it. Once you pointed this out I renamed it to .xlsx and it looks good.

Have you found a solution to this? It is due to the Microsoft.Interop.Excel class I believe.
The administrator has disabled public write access.
Time to create page: 0.036 seconds
Powered by Kunena Forum  Protected by R Antispam